Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • First step is to download Eclipse:
    • If you are a windows user you can find a link here: 32bit
    • If you are a linux user you can find the links here: 32bit and 64bit
    • If you are a Mac Cocoa user you can find the links here: 32bit and 64bit
  • Next step is to install subversion plugin for Eclipse called Subclipse. For that:
    • Start you your eclipse
    • Go to Help -> Install New Software...
    • In the "Install" dialog click on "Add..." button.
    • There "Add Site" dialog will prompt you for Plugin name and location. In the name field enter "Subclipse" and in the "Location" enter this link.
    • Click "OK".
    • After you set up Plugin location you will see Subclipse and its related components listed in the "Install" dialog. At least select all required components, click "Next" and continue with installation.
    • Once the installation is complete Eclipse will prompt you to restart itself and after that Subclipse installation will be completed.
  • Next step is to import all the source for Engage application into Eclipse:
    • Go to "File" -> "Import..." (Notice you will see and SVN option there because you just installed the Subclipse plugin for you Eclipse).
    • Click on SVN and then select "Checkout Projects from SVN".
    • On "Select/Create Location" choose "Create a new repository location" and in the URL specify:
      Code Block
      https://source.fluidproject.org/svn
    • Next step is to check out a project "fluid-all" that contains all necessary sub-projects and dependencies for engage application: on "Select Folder" page select fluid -> fluid-all folder and click next.
    • On the "Check Out As" page select "Check out as a project in the workspace". Click "Finish". After the operation completes you should have a fluid-all project listed in the Package Explorer.
  • So by now you should have the source for the whole Engage app checked out inside Eclipse however there are a few more steps on order to run the application:
    • Click on "File" -> "Import..." and on "Select" page choose "General" -> "Existing Projects into Workspace". Click next.
    • On "Import Projects" page select root directory as the one inside the recently checked out fluid-all called fluid-engage-kettle and click "Finish".
    • Now you have another "fluid-engage-kettle" project inside your Package Explorer ready and set up as the Java project.

...